• Welcome to videoedicion.org (v8.2). Please login or sign up.
 

PUBLICIDAD

Compra y colabora

Si usas estos banners para hacer tus compras, recibiremos una pequeña comisión. ¡Gracias por colaborar!



5% de descuento hasta fin de 2021
con el código VE20




Código VID15 para
un 15% en planes anuales



Welcome to Visitante. Please login or sign up.

08 de diciembre de 2021, 02:26:57

PUBLICIDAD

Temas Recientes

95 Visitantes, 0 Usuarios

PUBLICIDAD

DVDMaestro: Multiángulo interactivo en tiempo real (PROBLEMA - AVANZADO)

Iniciado por , 11 de enero de 2003, 05:40:36

Tema anterior - Siguiente tema

Hola, estoy haciendo un experimento con DVDMaestro, que consiste en un video multiángulo interactivo, de forma que el usuario pueda cambiar de ángulo en tiempo real, seleccionando opciones de un menú superpuesto. (Algo estilo al mosaico de Canal Satélite, pero mostrando los 7 ángulos y pudiendo navegar con los cursores y pinchar sobre ellos).

Para conseguirlo, he creado el video multiángulo normalmente, y le he puesto una subpicture/subtítulo de esos con botones (definir button highlits en la linea de tiempo, como los chapters), de forma que hay 7 botones navegables durante la reproducción del video. Para cada uno de esos botones, he marcado el checkbox Set Angle to del grupo Stream pre-selection, poniendo el número de ángulo respectivo a cada botón, y el target lo he dejado vacío porque evidentemente no quiero que salte a ningún sitio (quiero que el video siga reproduciéndose).

Y de momento el experimento funciona, el ángulo cambia normalmente, pero una cosa falla. En mi reproductor de mesa, al seleccionar un botón de cambio de ángulo y pulsarlo, el ángulo cambia, pero el botón queda en permanente estado de pulsación, y ya no puedo navegar más. En un reproductor de PC no hay problema, porque moviendo el ratón puedo pulsar en los demás, pero no consigo evitar este efecto cuando no lo hay.

Como imagino que será un problema del target vacío, he probado a vincularlo a la opcíón Resume, pero el video vuelve a empezar; al mismo video, con idéntico resultado; a una Command Sequence con una instrucción nop (no operar), pero se cuelga el reproductor; a otra command sequence que manualmente ponía el ángulo, pero también se colgaba, y ya no sé que hacer.

Sé que es un poco rebuscado, pero si alguien me ofreciese una solución les estaría enormemente agradecido.

PUBLICIDAD

El spam de este foro está controlado por CleanTalk