down

* Usuario

 
 
Bienvenido(a), Visitante. Por favor, ingresa o regístrate. ¿Perdiste tu email de activación?

Publicidad

* Calendario

Abril 2020
Dom Lun Mar Mié Jue Vie Sáb
1 2 3 4
5 6 7 [8] 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30

No hay eventos en el calendario.

* Conectados

  • Punto Visitantes: 27
  • Punto Oculto: 0
  • Punto Usuarios: 0

No hay usuarios conectados.

Se ve, pero no se oye.

Iniciado por vk, 01 de Abril de 2008, 18:26:14

Tema anterior - Siguiente tema

vk

Hola:

Hace un par de meses me regalaron un lector de DVDs portatil, de marca BELSON (Mod. BS-130806).

Si bien sé que el aparato es el más económico de la gama, por el momento me está funcionando perfectamente con casi todas las películas que he bajado de internet y he intentado ver.

El problema que tengo no es con la imagen; sino con el audio.

Lo que no entiendo es que en un detector de codecs he examinado una película que sí se oye y otra que no, y resulta que ambas tienen el mismo codec de audio.

Agradecería información sobre porqué dos películas con el mismo codec de sonido tienen distinto resultado en la reproducción del lector de DVD portatil; y agradecería que alguien me explicase lo más detalladamente posible, cómo recodificar ese audio para que el lector sí lo reproduzca.

Es evidente que en este terreno tengo muy pocos conocimientos, por lo que agradezco la paciencia y las explicaciones detalladas.

Un saludo y gracias por la atención prestada.

Fdo.: VK.

nij

Cita de: "vk"en un detector de codecs he examinado una película que sí se oye y otra que no, y resulta que ambas tienen el mismo codec de audio.
¿Y el mismo codec y formato de vídeo? ¿Cuales?
Dare cuique suum. -  (Asociación de Editores de Vídeo Digital) ya está en marcha -
A todos nos han cantado, en una noche de juerga, coplas que nos han matado.

vk

Disculpa que haya tardado un poco en responder, y gracias por interesarte por esta consulta.

El códec de audio es:  MPEG-1 Layer 3.

El GSpot indica que es el mismo códec tanto en los archivos que el reproductor "sonoriza", como los que no se oyen.

El problema es igual tanto en audios de 44100Hz  128 kb/s total (2 chnls), como en audios de 48000Hz  128 kb/s total (2 chnls), así que me imagino que el sample rate y la resolución dan un poco igual.

Sin más por ahora, un saludo.

Fdo.: VK.

equus

Fíjate si gspot señala CBR o VBR en ambos y si no, cuál de ellos te da problemas.
También fíjate si en el cuadro de "metadata" te da más datos, por ejemplo el programa que usaron para comprimir/multiplexar

vk

Sin querer llegar a ser demasiado pesado, reitero mi agradecimiento por la ayuda.

Un saludo (otro más).

Fdo.: VK.


P. D.: Aquí van los datos del GSpot:


- Del archivo que se oye:

Apartado User Data / Metadata:

[ISFT]   VirtualDubMod 1.5.10.2 (build 2540/release)
[JUNK]    VirtualDubMod build 2540
[JUNK]    release
[USER]    XviD0046
[USER]    XviD0046
[USER]    XviD0046

Apartado audio:

Codec: 0x0055(MP3, ISO) MPEG-1 Layer 3
Info: 48000Hz  128 kb/s total (2 chnls)
CBR




- Del archivo que no se oye:

Apartado User Data / Metadata:

[ISFT]     VirtualDubMod 1.5.10.2 (build 2540/release)
[JUNK]    VirtualDubMod build 2540
[JUNK]    release
[USER]    XviD0046
[USER]    XviD0046
[USER]    XviD0046


Apartado audio:

Codec: 0x0055(MP3, ISO) MPEG-1 Layer 3
Info: 48000Hz  128 kb/s total (2 chnls)
CBR



- De otro archivo que tampoco se oye:

Apartado User Data / Metadata:

[ISFT]     VirtualDubMod 1.4.13
[JUNK]    VirtualDub build 14328
[JUNK]    release
[USER]    XviD0046
[USER]    XviD0046
[USER]    XviD0046


Apartado audio:

Codec: 0x0055(MP3, ISO) MPEG-1 Layer 3
Info: 44100Hz  128 kb/s total (2 chnls)
CBR

equus

Comprueba, por último, si están habilitadas las opciones de QP, GMC, PB alguna, todas cuáles?.

Por mi parte voy a trastear con mi "belson" con esas opciones habilitadas y veré si se produce algún problema.

equus

Lo siento, prueba superada, se lo traga tooo: QP, GMC, PB, y las combinaciones entre ellos.
El modelo exacto del mio es el BSV-0702.
Como última prueba te propongo que extraigas el audio con virtualdubmod, pruebes que la cadena de audio se escuche sin problemas sola y que vuelvas a multiplexarla (unirla) a la cadena de video original, sólo por probar, no sea el problema un bit perdido o una mal encadenamiento entre video y audio.

Vamos, todo esto suponiendo que en el reproductor de pc se "escuche"   , a ver si la cadena de audio está llena de silencio .........  

vk

Ups...  

Aquí es donde me temo que van a empezar los problemas para mí.

Ese programa no lo controlo y no sé cómo hacer lo que me dices.

Para colmo está en "inglis pitinglis".

Si tú tienes tiempo y ganas de enseñarme un poco, yo tengo paciencia y deseo de aprender.

Soy todo ojos.

Gracias de nuevo.

Fdo.: VK.

equus

Primero mira de nuevo en gspot, a la derecha en el cuadro referente a video, debes comparar qué es lo que está diferente (o no), entre el video que puedes reproducir y los que no. Te adjunto una toma de gspot donde enmarco los parámetros que debes comparar y en los que se ven activadas el GMC, qpel y pb


vk

Tengo más archivos que el reproductor se niega a "sonorizar", pero funciona porque otros se ven y se oyen sin ningún problema.

Aquí te dejo una captura de lo que me dices, no sé si te servirá para hacerte una idea de lo que me comentas:



Gracias otra vez.

Fdo.: VK.

equus

Mi último recurso, no me quedan mas ideas del por qué falla el audio. Vamos a separar las cadenas (Video y audio) y volverlas a unir:

Necesitas el virtuadub: https://videoedicion.org/index.php?i ... ew&iden=14

1) Carga el video con problemas.
2) En el menu File, selecciona save wav ..., llámale audio.mp3 (ya que ese es su formato) y elige la carpeta donde quieres guardarlo. Carga este fichero en tu reproductor de pc y comprueba que "suene".
3) En el menu Video, selecciona Direct Stream Copy. El el menu File, selecciona Save avi...  llámale Video y elige la carpeta donde guardaste el audio.
4) Ahora, carga el fichero que hemos llamado Video, en el menu Audio selecciona Wav audio y carga el que habíamos llamado Audio.mp3 (en este punto hacerte notar que por defecto virtualdub espera una cadena audio.wav, con lo que en tipo selecciona *.*) y podrás cargar el mp3.
Otra vez en el menu Video para comprobar que está seleccionado el Direct Stream copy y sólo queda de nuevo el Save avi al que llamaremos Video+Audio
5) Comprueba si este nuevo fichero Video+Audio.avi sí que se le "oye".

Breve explicación de lo que haces:
En 2), simplemente obtenemos la cadena de audio
En 3), obtenemos la de video.
En 4) las volvemos a unir en un único fichero.


Suerte!

vk

Perdona que haya tardado tanto en responder. He tenido algún problema personal sin demasiada importancia que me ha impedido hacerlo cuando debería haberlo hecho.

El post lo leí, pero no podía escribir y preferí dejarlo para un poco más adelante.



En cuanto tenga un ratito haré esto que me dices y te comentaré el resultado.

La parte del audio la conozco un poco más, pero por el uso de "Cool Edit Pro", ahora "Adobe Audition".

Tampoco quiero aburrir, así que aquí termino por ahora.

Gracias, en serio.

Un saludo.

Fdo.: VK.

vk

Hola otra vez:

Tras seguir todos y cada uno de los pasos con tres videos distintos que tenían el mismo problema, el resultado creo que no ha sido todo lo bueno que esperaba.

Hay dos que continúan sin oirse, y el tercero, se oye solamente una de cada cuatro veces que intento reproducirlo.

El resto de las veces aparece bien un mensaje indicando que el reproductor no soporta el audio, o bien que no soporta ni el formato de audio, ni el de video.

Lejos de desanimarme admito que cada vez tengo más curiosidad por saber a qué se debe esto, jajajajajaja.

Así que si te quedan ganas y curiosidad, me encantaría que me guiases hasta el final de este "video-misterio".

Como siempre, gracias por el interés, la ayuda, y el tiempo que me dedicas.

Hasta otro rato.

Fdo.: VK.

equus

Lo único que puedo ofrecerte es que me mandes pequeños trozos de los videos con problemas (10 sg bastarán) y ofrezco mi belson para hacer la prueba y repetir el proceso de virtualdub, pero es que no sé qué más puede suceder.

vk

Tampoco es mi intención hacerte perder el tiempo más de lo que ya lo has hecho con esta consulta.

Tus pautas me han sido muy útiles si tenemos en cuenta que uno de los videos se se ha "arreglado".

Esto me lleva a pensar que el lector es el que realmente tiene problemas de lectura. Lo que no sé es porque unos archivos si los lee y otros no.

De todas formas ya te digo que tus comentarios me han sido muy útiles porque de paso he aprendido cómo extraer el audio y cómo volver unirlo otra vez.

Espero sacarle partido a esto, así que muchísimas gracias por todo.

Hasta pronto.

Fdo.: VK.

Powered by SMFPacks Menu Editor Mod
Powered by SMFPacks Media Embedder