• Welcome to videoedicion.org (v8.2). Please login or sign up.
 

PUBLICIDAD

Compra y colabora

Si usas estos banners para hacer tus compras, recibiremos una pequeña comisión. ¡Gracias por colaborar!



5% de descuento hasta fin de 2021
con el código VE20




Código VID15 para
un 15% en planes anuales



Welcome to Visitante. Please login or sign up.

05 de diciembre de 2021, 12:14:25

PUBLICIDAD

Temas Recientes

79 Visitantes, 0 Usuarios

PUBLICIDAD

Vídeo renderizado con la imagen en negro y solo el audio.

Iniciado por wamba, 03 de julio de 2021, 16:52:20

Tema anterior - Siguiente tema

wamba

Hola, buenas tardes  :)

Soy nuevo en el foro y espero poder aprender paso a paso la literatura de la edición de vídeo. De momento voy mezclando y probando cosas para irme familiarizando con el programa.

Os comento, estoy teniendo un problema con la renderización completa de los vídeos. Una vez que estoy visualizándolo, se escucha pero la pantalla se ve en negro. He probado con el Videolan y el reproductor de Windows, pero el resultado es el mismo.

Supongo que el fallo será de algún códec o algo, pero me gustaría saber si el fallo puede ser también ocasionado por alguna característica activada en la configuración del programa o algo similar.

Para más señas, el Sony Vegas que utilizo es la versión Pro 17.0, y los formatos utilizados son MAGIX AVC y HEVC Internet HD 720p 25fps (Intel QSV).

XarquS

Hola y bienvenido:

Se necesitan más datos para saber o tratar de saberlo. Deberías aclarar algunos detalles:


Cita de: wamba en 03 de julio de 2021, 16:52:20estoy teniendo un problema con la renderización completa de los vídeos. Una vez que estoy visualizándolo, se escucha pero la pantalla se ve en negro. He probado con el Videolan y el reproductor de Windows, pero el resultado es el mismo.
¿Pero lo puedes ver en el preview de Vegas? En la terminología de Vegas renderizado significa video exportado, terminado. Supongo que quieres decir eso, ¿cierto?



Cita de: wamba en 03 de julio de 2021, 16:52:20me gustaría saber si el fallo puede ser también ocasionado por alguna característica activada en la configuración del programa o algo similar.
Aunque no puedo afirmarlo, los tiros podrían ir por ahí. Si en el preview lo puedes ver y a veces saltan cuadros negros, puede ser que tengas que desactivar la tarjeta si usas nVidia. Pero eso tendrás que aclararlo también.


Sería interesante que pusieras las características de los videos originales, no los renderizados. Aquí te explico, por si lo necesitas, como hacerlo:





X.
"...a pesar de ellos, yo soy del Sur y de la mar" (María Zambrano).

wamba

Buenas tardes :-)

Gracias por su respuesta XarquS.

Te comento, en la previa de Vegas si puedo ver el vídeo ya configurado (y sin configurar) con los efectos aplicados y en ningún momento saltan cuadros negros, pero una vez renderizado y reproducido en el Videolan, o el reproductor de Windows, solamente se escucha.

He probado esta mañana a realizar el renderizado con otro formato, el XDCAM EX, y el vídeo ya se ve, así que supongo que el problema de que no se vea será a causa de los formatos. 

Las características del vídeo son las siguientes:

Formato[/b]                             : MPEG-4
Formato del perfil                      : Base Media
ID códec                                : isom (isom/3gp4)
Tamaño de archivo                       : 259 MiB
Duración                                : 2 min 59 s
Tasa de bits general                    : 12,1 Mb/s


Vídeo
ID                                      : 1
Formato                                 : AVC
Formato/Info                            : Advanced Video Codec
Formato del perfil                      : Baseline@L3.1
Ajustes del formato                     : 1 Ref Frames
Ajustes del formato, CABAC              : No
Ajustes del formato, RefFrames          : 1 fotograma
Ajustes del formato, GOP                : M=1, N=30
ID códec                                : avc1
ID códec/Info                           : Advanced Video Coding
Duración                                : 2 min 58 s
Duración original                       : 2 min 58 s
Tasa de bits                            : 12,0 Mb/s
Ancho                                   : 1 280 píxeles
Alto                                    : 720 píxeles
Relación de aspecto                     : 16:9
Modo velocidad fotogramas               : Variable
Velocidad de fotogramas                 : 30,000 FPS
Velocidad fotogramas mínima             : 19,702 FPS
Velocidad fotogramas máxima             : 31,088 FPS
Espacio de color                        : YUV
Submuestreo croma                       : 4:2:0
Profundidad bits                        : 8 bits
Tipo barrido                            : Progresivo
Bits/(píxel*fotograma)                  : 0.434
Tamaño de pista                         : 256 MiB (99%)
Cantidad de pistas original             : 256 MiB (99%)
Título                                  : VideoHandle
Idioma                                  : Inglés
Fecha de codificación                   : UTC 2021-07-01 21:25:33
Fecha de etiquetado                     : UTC 2021-07-01 21:25:33
mdhd_Duration                           : 178956
Codec configuration box                 : avcC

Audio
ID                                      : 2
Formato                                 : AAC LC
Formato/Info                            : Advanced Audio Codec Low Complexity
ID códec                                : mp4a-40-2
Duración                                : 2 min 59 s
Tipo de tasa de bits                    : Constante
Tasa de bits                            : 128 kb/s
Canal(es)                               : 2 canales
Channel layout                          : L R
Velocidad de muestreo                   : 48,0 kHz
Velocidad de fotogramas                 : 46,875 FPS (1024 SPF)
Modo de compresión                      : Con pérdida
Tamaño de pista                         : 2,71 MiB (1%)

Un saludo ;-)

XarquS

En principio veo que los fps son variables (suelen ser videos de celulares), y eso suele ser muy malo para casi todos los programas, aunque ya la 18 de Vegas Pro parece que se va arreglando con esto. Te propongo algunas soluciones porque, en principio, las plantillas de salida que comentas no tienen porqué tener problemas, aunque suelen darlo con este tipo de video:

A- Recodifica con Xmedia Recode los clips a usar con un codec sin pérdida y usando unos fps estandard. 

B- Desactiva la aceleración gráfica en el preview y en el render:



C- Desactiva el nuevo descodificador:


Y a ver si tenemos suerte con alguna medida de estas. Por último, asegúrate de que no has dejado por descuido activado el mute de la pista de video.


X.



"...a pesar de ellos, yo soy del Sur y de la mar" (María Zambrano).

wamba

Hola, buenas tardes :-)

Ya he conseguido ver el vídeo con la opción de recodificar con Xmedia Recode. Una vez hecho la recodificación, lo añadí al Sony Vegas, le añadí una serie de efectos y lo rendericé con los formatos MAGIX AVC y HEVC a 720p, y ya lo pude visualizar en el VideoLan y en el reproductor de Windows.

Lo único que no hice con el XMedia Recode fue lo de usar unos fps estándar, básicamente porque no conseguí dar con la opción (supongo que sería por las prisas). Lo que hice fue, una vez añadido en vídeo original, irme a opciones de vídeo, modo y activar copiar, y en audio lo hice igual (seguí los pasos de un video tutorial que hay colgado en este foro sobre XMedia). 

Un saludo y gracias por la ayuda ;-)


PUBLICIDAD


XarquS

"...a pesar de ellos, yo soy del Sur y de la mar" (María Zambrano).

PUBLICIDAD

El spam de este foro está controlado por CleanTalk