collapse

Publicidad

Reportar al moderador

No hay moderadores "de oficio" revisando los mensajes publicados en los foros. Sin embargo, se actúa con la máxima diligencia posible cuando alguien reporta algún contenido inapropiado.
Por favor, ayuda a mantener el foro en orden usando la opción "Reportar al moderador" que encontrarás en la esquina inferior derecha de cada mensaje siempre que lo estimes conveniente. Gracias.

Se buscan voluntarios que ayuden a etiquetar mensajes

Se buscan voluntarios que ayuden a etiquetar mensajes ¡Gracias!

[ Más información aquí ]

Tus datos

Bienvenido(a), Visitante. Por favor, ingresa o regístrate. ¿Perdiste tu email de activación?

Publicidad

Calendario

Septiembre 2019
Dom Lun Mar Mié Jue Vie Sáb
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 [19] 20 21
22 23 24 25 26 27 28
29 30

No se encontraron eventos en el calendario.

Usuarios conetados

  • Punto Visitantes: 61
  • Punto Oculto: 0
  • Punto Usuarios: 0

No hay usuarios en linea.

Estadísticas

  • stats Total de Usuarios: 54,949
  • stats Total de Mensajes: 446,931
  • stats Total de Temas: 77,226
  • stats Total de Categorías: 6
  • stats Total de Foros: 121
  • stats Máx. usuarios conectados (simultáneamente): 507

Publicidad

 Problemas con video capturado en movil

Iniciado por Aleksey, 04 de Junio de 2019, 00:45:14

Tema anterior - Siguiente tema

Aleksey

Buen día a todos!, como andan? Soy nuevo por este foro, apenas soy novato en la producción de video y ando aprendiendo, veo que en el foro hay gente que sabe montones, por eso vengo en busca de ayuda con un tema que me tiene loco, ya llevo 3 días y nada que puedo solucionarlo, mi problema es el siguiente:

Voy a extenderme para tratar de que no queden dudas y aclarar todos los puntos que yo considero importantes. He estado aprendiendo a grabar con ajustes manuales, siguiendo indicaciones de foros y tutoriales muy completos (incluso vi un video donde se usan las mismas configuraciones al grabar y quien lo hace explica el porqué, el resultado es magistral usando un móvil gama media) he aprendido iso, apertura, obturación, fotogramas, en busca de obtener buena calidad para un chroma key con una iluminación media como es la que tengo en mi habitación, mi limitante es que solo tengo en mi poder un teléfono móvil, concretamente un LG G4, he descargado varias apps (incluso una de pago) para controlar la cámara de manera manual al hacer video ya que la app nativa de mi teléfono no me lo permite y además agrega mucho ruido al resultado final, las apps en modo manual funcionan bien (dando unos resultados increíbles y reproduciéndose bien en el móvil) el problema está al copiar el video al pc, en ese momento, cuando lo reproduzco, empieza a dar saltos muy extraños (y extremadamente notables). Para reproducir los videos he usado la app de w10 por defecto, adobe premiere y after effects, en todos sucede lo mismo (solo se ve bien en el reproductor de Windows media), como aclaración, el bitrate no creo que sea el problema, ya he reproducido videos con muchísimo más bitrate y todos van super fluidos

Los ajustes al grabar el video en todas las apps:
1920 x 1080 (excepto en la app de pago que me permitía 4k)
Fps 30 que es lo que permite el móvil
Iso 100
Opturación 1/30
Apertura no puedo controlarla
(con ajustes automáticos en las apps también da el mismo problema)

Mi computadora:
Procesador I7 6700 3.4 GHz
Ram 16 Gb 2x8
Gráfica Asus Strix 1060 6Gb
2 Discos duros 1 y 2 Tb respectivamente

Este es un video capturando la pantalla para mostrar como se ve ese video en concreto en mi computadora ya que al verlo en google drive no da ese problema:

https://drive.google.com/file/d/1Ty0-jdwxsTlDSYMUJY2nDSGgLs1eW2P0/view?usp=sharing

Este es el link del video que me da problemas
(uno de tantos, todos dan el mismo problema, solo elegí este por ser el que mas me gustó en calidad):


https://drive.google.com/file/d/1mpa4r-7K2AG_I3XPN31J9ou-RBuMDTi2/view?usp=sharing

Espero atento sus respuestas, y gracias a todos de antemano

Poucopelo

Bienvenido Aleksey.
Es un tema bastante complejo, que analizaremos por partes:

Cita de: Aleksey en 04 de Junio de 2019, 00:45:14Para reproducir los videos he usado la app de w10 por defecto, adobe premiere y after effects, en todos sucede lo mismo (solo se ve bien en el reproductor de Windows media)
Al reproducir no puedes esperar los mismos resultados de Windows Media que de After Effects.
Un reproductor, ya sea Windows Media, VLC, MPV o cualquier otro, tiene como única función el reproducir el vídeo en tiempo real y a pantalla completa.

En Premiere, After o cualquier programa de edición, el monitor está pensado para intentar reproducir una línea de tiempos donde hay una serie de elementos: vídeos en un determinado orden, con efectos (algunos muy exigentes), gráficos, audios, etc.
Y su función es hacerlo lo más fluído posible, y lo más parecido al resultado final.

Desde el momento en que en Premiere o en After creas un proyecto con unas dimensiones, una tasa de fotogramas y un formato de previsualización, estás condicionando el comportamiento del programa. Me explico:
He grabado un vídeo a 1920 x 1080 / 25 fps, y creo una secuencia en Premiere a 1280 x 720 / 30 fps (por poner un ejemplo).
Cuando le doy al PLAY, el programa va a reescalar ese vídeo, y va a intentar acomodar esos 25 fps de origen en una secuencia de 30 fps. Y va a intentar hacerlo en tiempo real, para que pueda editar y añadir efectos con fluidez.

Cita de: Aleksey en 04 de Junio de 2019, 00:45:14Los ajustes al grabar el video en todas las apps:
1920 x 1080 (excepto en la app de pago que me permitía 4k)
Fps 30 que es lo que permite el móvil
Iso 100
Opturación 1/30
Apertura no puedo controlarla
(con ajustes automáticos en las apps también da el mismo problema)
Pese a que dices que graba a 30 fps, tengo la sospecha de que el móvil lo hace con una tasa de fotogramas variable (cuadra con el comportamiento que se ve en el vídeo), cosa que no le gusta a Premiere, y menos aún a After.

Para no andar con suposiciones, usa MediaInfo en modo Texto, copia y pega los datos que salgan.
MediaInfo es una utilidad que aporta mucha información sobre archivos de vídeo y audio. La consigues aquí:
https://mediaarea.net/es/MediaInfo

Además vendrían bien unos pantallazos de los ajustes de secuencia en Premiere o After.

Esperamos tu respuesta. Saludos.

Aleksey

Hola Poucopelo, muchas gracias por tomarte el tiempo de responder.

Voy por partes, lo primero es responder a lo que me dices.


Esta es la info que me da el mediainfo del archivo que va mal:

General
Complete name                            : C:\Users\yomar\Desktop\mejor.mp4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42 (isom/mp42)
File size                                : 46.6 MiB
Duration                                 : 12 s 970 ms
Overall bit rate                         : 30.2 Mb/s
Performer                                : LGE
Encoded date                             : UTC 2019-06-03 00:14:38
Tagged date                              : UTC 2019-06-03 00:14:38
com.android.version                      : 6.0

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings                          : CABAC / 2 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 2 frames
Format settings, GOP                     : M=2, N=31
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 12 s 838 ms
Source duration                          : 12 s 891 ms
Bit rate                                 : 29.7 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Rotation                                 : 180°
Frame rate                               : 28.743 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.498
Stream size                              : 45.5 MiB (97%)
Source stream size                       : 45.6 MiB (98%)
Title                                    : VideoHandle
Language                                 : English
Encoded date                             : UTC 2019-06-03 00:14:38
Tagged date                              : UTC 2019-06-03 00:14:38
mdhd_Duration                            : 12838
Codec configuration box                  : avcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 12 s 970 ms
Bit rate mode                            : Constant
Bit rate                                 : 156 kb/s
Nominal bit rate                         : 96.0 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 247 KiB (1%)
Title                                    : SoundHandle
Language                                 : English
Encoded date                             : UTC 2019-06-03 00:14:38
Tagged date                              : UTC 2019-06-03 00:14:38
mdhd_Duration                            : 12970


Acá la captura de pantalla de la configuración en premiere, suelo crear las secuencias arrastrando el video para que esta tome las configuraciones directamente desde el mismo, pero veo que no coinciden con el frame rate "extraño" y bajo del video:


https://drive.google.com/file/d/1GX2TeYbiwhzGHCHYiOa_wy0SLgFKZEIz/view?usp=sharing


Actualizo descubrimientos por mi parte

He pasado gran parte de la noche haciendo pruebas con toda app que se me atraviesa y he encontrado dos cosas

Lo primero es que descubrí un desarrollador que tomó la app nativa del móvil y la modificó para poder usar ajustes manuales en video, debo decir que, con esa app, si configuro correctamente (1080 o 4k, 30 o 60 fps, iso 150, obturación 1/60, super importante el bitrate a medio), el problema no se da en los videos finales, esta es la info de uno de esos archivos:

General
Complete name                            : C:\Users\yomar\Downloads\vid\4k 150 1-60.mp4
Format                                  : MPEG-4
Format profile                          : Base Media / Version 2
Codec ID                                : mp42 (isom/mp42)
File size                                : 135 MiB
Duration                                : 23 s 850 ms
Overall bit rate                        : 47.3 Mb/s
Performer                                : LGE
Encoded date                            : UTC 2019-06-04 04:52:25
Tagged date                              : UTC 2019-06-04 04:52:25
com.android.version                      : 6.0

Video
ID                                      : 1
Format                                  : AVC
Format/Info                              : Advanced Video Codec
Format profile                          : High@L5.1
Format settings                          : CABAC / 2 Ref Frames
Format settings, CABAC                  : Yes
Format settings, Reference frames        : 2 frames
Format settings, GOP                    : M=2, N=31
Codec ID                                : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                : 23 s 387 ms
Source duration                          : 23 s 392 ms
Bit rate                                : 47.9 Mb/s
Width                                    : 3 840 pixels
Height                                  : 2 160 pixels
Display aspect ratio                    : 16:9
Frame rate mode                          : Variable
Frame rate                              : 30.000 FPS
Minimum frame rate                      : 26.510 FPS
Maximum frame rate                      : 30.477 FPS
Color space                              : YUV
Chroma subsampling                      : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                      : 0.193
Stream size                              : 134 MiB (99%)
Source stream size                      : 134 MiB (99%)
Title                                    : VideoHandle
Language                                : English
Encoded date                            : UTC 2019-06-04 04:52:25
Tagged date                              : UTC 2019-06-04 04:52:25
mdhd_Duration                            : 23387
Codec configuration box                  : avcC

Audio
ID                                      : 2
Format                                  : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                : mp4a-40-2
Duration                                : 23 s 850 ms
Bit rate mode                            : Constant
Bit rate                                : 156 kb/s
Nominal bit rate                        : 96.0 kb/s
Channel(s)                              : 2 channels
Channel layout                          : L R
Sampling rate                            : 48.0 kHz
Frame rate                              : 46.875 FPS (1024 SPF)
Compression mode                        : Lossy
Stream size                              : 454 KiB (0%)
Title                                    : SoundHandle
Language                                : English
Encoded date                            : UTC 2019-06-04 04:52:25
Tagged date                              : UTC 2019-06-04 04:52:25
mdhd_Duration                            : 23850



Lo segundo es que encontré otra app que, aunque es más básica, tampoco me da errores de ese tipo, y mejora, como todas las demás, un poco la nitidez final con respecto a la cámara por defecto del G4 (que no me gusta la manera en la que procesa la imágen, da un efecto "acuarela" en los bordes que las otras apps no), sin embargo he notado que las apps de terceros a veces cambian, aún con los parámetros bloqueados, la exposición de manera repentina, aún sin cambios en la escena, y se quedan así hasta que le doy un toque a la pantalla, y de todas maneras vuelve y cambia, a veces cada 2 o 3 segundos sucede y no sé por qué, ignoro si tiene algo que ver, pero sospecho que quizá el movil tenga problemas para que las apps de terceros funcionen correctamente.

Poucopelo

Lo que veo en los datos me confirma la sospecha: los vídeos están grabados con un framerate variable:
En el primer vídeo informa que a 28.743 fps, que es un valor muuuuuy extraño. Y aún más extraño si vemos que Premiere ajusta la secuencia a 14,89 fps. No lo especifica (MediaInfo no siempre consigue toda la información), pero con certeza es una tasa variable.
En el segundo vídeo el dato es evidente y lo pone: Frame rate mode > Variable.

Ya dije que a los programas de edición no les gusta ese tipo de cosas. Esperan que el material esté grabado a una tasa de fotogramas constante.

¿Qué hacer?. Sería importante que el móvil grabara a una tasa constante, pero si no fuera posible hay soluciones para zafar y trabajar con lo ya grabado.

La más simple es convertir el material a un formato sin pérdidas y con el framerate constante. Programas como TmpegEnc o XMediaRecode pueden hacerlo.

Otra opción es crear en Premiere una secuencia del tamaño del vídeo y 30 fps. Seleccionar el vídeo > Clip > Modify > Interpret Footage > Assume this frame rate: 30 fps.

Luego hacer un Render y si todo va bien, continuar la edición.


Dos cosas a mayores.
Te veo muy preocupado por los ajustes de exposición, ISO, etc, cosa que está muy bien. Pero no veo la misma preocupación en iluminar correctamente la escena, y eso es primordial. Y aún más cuando luego vas a hacer un chroma.

La segunda es que en el vídeo del primer mensaje se ve claramente como la exposición fluctúa cuando mueves las manos, o sea que el móvil sigue trabajando en automático.

Saludos.

Aleksey

Que tal Poucopelo, muchas gracias de nuevo por responder. Tienes razón, Convertir el video lo soluciona, no va fluido por los pocos fotogramas que tiene, pero eso es culpa del móvil; lo de "Interpret Footage" no funciona, simplemente hace más rápido el video, pero el "shake" continúa y así es imposible editar.

El material que ves no es final, simplemente lo hice para probar el modo manual de la cámara y me encontré con este problema, pero ese video va a la papelera de reciclaje, por eso la mala iluminación, de hecho ni siquiera está bien templada la tela, lo de iluminar la escena es claro, justo esta tarde estaba buscando en el mercado las luces, pero es un tema que aún no domino muy bien.

El problema de que la exposición fluctúa, exactamente a eso me refiero cuando digo que a veces las apps cambian la exposición de manera repentina aún estando bloqueados los parámetros, voy a hacer más pruebas con la app nativa y esperemos que funcione todo.

Poucopelo

Cita de: Aleksey en 06 de Junio de 2019, 02:18:14pero eso es culpa del móvil;
¿Y no te compensaría comprar una cámara de vídeo o de fotos-vídeo?. Incluso un modelo sencillo no tendría estos problemas.

Saludos.

XarquS

De los mejores consejos que he leído últimamente... Salud Maestro Poucopelo.

X.
"...a pesar de ellos, yo soy del Sur y de la mar" (María Zambrano).


SMF spam blocked by CleanTalk
Powered by SMFPacks Menu Editor Mod
Powered by SMFPacks Media Embedder